re = /(?:(?<=[^\\])|^)(\\(?:\\{2})*)(?=[^\\]|$)/m
str = '\\startofline \\\\
\\ asf
sring\\e
yappadoo\\\\\\n
\\\\\\\\ fine
this is not\\\\\\\\\\
\\\\\\\\\\\\\\
good\\\\nstring\\\\n and fine\\\\t
this is\\nbad
indent\\\\t
\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end