$re = '/(?:(?<=[^\\\\])|^)(\\\\(?:\\\\{2})*)(?=[^\\\\]|$)/m';
$str = '\\startofline \\\\
\\ asf
sring\\e
yappadoo\\\\\\n
\\\\\\\\ fine
this is not\\\\\\\\\\
\\\\\\\\\\\\\\
good\\\\nstring\\\\n and fine\\\\t
this is\\nbad
indent\\\\t
\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);