#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<=[^\\])|^)(\\(?:\\{2})*)(?=[^\\]|$)"
Local $sString = "\startofline \\" & @CRLF & _
"\ asf" & @CRLF & _
"sring\e" & @CRLF & _
"" & @CRLF & _
"yappadoo\\\n" & @CRLF & _
"\\\\ fine" & @CRLF & _
"this is not\\\\\ " & @CRLF & _
"\\\\\\\" & @CRLF & _
"" & @CRLF & _
"good\\nstring\\n and fine\\t" & @CRLF & _
"this is\nbad" & @CRLF & _
"indent\\t" & @CRLF & _
" \"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")