const regex = new RegExp('(sudo)(?:\\[\\d+\\])?\\:\\s+(?:\\[[^]]+]\\s+)?(\\S+)\\s*\\:\\s*TTY=([^ ;]+)\\s*;\\s*PWD=([^ ;]+)\\s*;\\s*USER=([^ ;]+)\\s*;\\s*COMMAND=([^\\"]+)', 'gm')
const str = `{"xif_srcip":"10.0.252.164","sl_fac":"authpriv","sl_sev":"notice","sl_pri":"85","sl_h":"security-alerts-test-1","message":"sudo: root : TTY=pts/4 ; PWD=/root ; USER=root ; COMMAND=/sbin/insmod","ident":"sudo","xif_pfx":"syslog","xif_fwdr":"security-fluentd-iad01-ppd-01.us-east-1a.preprod.ntnxi.net","xif_fwdrip":"10.254.0.6","xih_s":"_","xif_tag":"syslog.authpriv","time":"2019-07-17T20:25:45.700914000Z"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}