import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(sudo)(?:\\[\\d+\\])?\\:\\s+(?:\\[[^]]+]\\s+)?(\\S+)\\s*\\:\\s*TTY=([^ ;]+)\\s*;\\s*PWD=([^ ;]+)\\s*;\\s*USER=([^ ;]+)\\s*;\\s*COMMAND=([^\\\"]+)";
final String string = "{\"xif_srcip\":\"10.0.252.164\",\"sl_fac\":\"authpriv\",\"sl_sev\":\"notice\",\"sl_pri\":\"85\",\"sl_h\":\"security-alerts-test-1\",\"message\":\"sudo: root : TTY=pts/4 ; PWD=/root ; USER=root ; COMMAND=/sbin/insmod\",\"ident\":\"sudo\",\"xif_pfx\":\"syslog\",\"xif_fwdr\":\"security-fluentd-iad01-ppd-01.us-east-1a.preprod.ntnxi.net\",\"xif_fwdrip\":\"10.254.0.6\",\"xih_s\":\"_\",\"xif_tag\":\"syslog.authpriv\",\"time\":\"2019-07-17T20:25:45.700914000Z\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}