re = /(?<!\S)\d(?!\S)/m
str = '3 people, 20 hours, 33 chairs, 11 minutes, 4 days, 5.50€, 3 instances, 7 miles'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end