$re = '/(?<!\S)\d(?!\S)/m';
$str = '3 people, 20 hours, 33 chairs, 11 minutes, 4 days, 5.50€, 3 instances, 7 miles';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);