const regex = /(?<!\S)\d(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)\\d(?!\\S)', 'gm')
const str = `3 people, 20 hours, 33 chairs, 11 minutes, 4 days, 5.50€, 3 instances, 7 miles`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}