re = /[^?](?<issue>.*?-\d+) ?[^?]\s(?<desc>.*)/m
str = '[ESHOP-7830] BAU (Business as usual) - Jira'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end