package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^?](?<issue>.*?-\d+) ?[^?]\s(?<desc>.*)`)
var str = `[ESHOP-7830] BAU (Business as usual) - Jira`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}