$re = '/[^?](?<issue>.*?-\d+) ?[^?]\s(?<desc>.*)/m';
$str = '[ESHOP-7830] BAU (Business as usual) - Jira';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);