$re = '/(http(s)?:\/\/)?(www.)?(formable\.se(?!\/almega)\/\S*)/m';
$str = 'formable.se/xxxx122..44442xxxxxx gfgdff
http://www.formable.se/almega/xxxx122..44442xxxxxx gfgdff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);