import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s)?:\\/\\/)?(www.)?(formable\\.se(?!\\/almega)\\/\\S*)";
final String string = "formable.se/xxxx122..44442xxxxxx gfgdff\n"
+ "http://www.formable.se/almega/xxxx122..44442xxxxxx gfgdff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}