#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http(s)?:\/\/)?(www.)?(formable\.se(?!\/almega)\/\S*)"
Local $sString = "formable.se/xxxx122..44442xxxxxx gfgdff" & @CRLF & _
"http://www.formable.se/almega/xxxx122..44442xxxxxx gfgdff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")