$re = '/.?\<(\d+?)\>/m';
$str = '2e<3123>123<1231><3123>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);