using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".?\<(\d+?)\>";
string input = @"2e<3123>123<1231><3123>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}