package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).?\<(\d+?)\>`)
var str = `2e<3123>123<1231><3123>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}