re = /(?<![\=\"])<\?(php|\s+|\=)(.+?)\?>/i
str = '<strong> <?= $row[\'name\']; ?> </strong>
href="<?= $row[\'url\']; ?>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end