$re = '/(?<![\=\"])<\?(php|\s+|\=)(.+?)\?>/is';
$str = '<strong> <?= $row[\'name\']; ?> </strong>
href="<?= $row[\'url\']; ?>"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);