using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\=\""])<\?(php|\s+|\=)(.+?)\?>";
string input = @"<strong> <?= $row['name']; ?> </strong>
href=""<?= $row['url']; ?>""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}