re = /^(\d{3}\.\d{3}\.\d{3}\-\d{2})$/
str = '190.521.157-89'
subst = 'CNPJ'
result = str.sub(re, subst)
# Print the result of the substitution
puts result