use strict;
my $str = '190.521.157-89';
my $regex = qr/^(\d{3}\.\d{3}\.\d{3}\-\d{2})$/p;
my $subst = 'CNPJ';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";