package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d{3}\.\d{3}\.\d{3}\-\d{2})$`)
var str = []byte(`190.521.157-89`)
var substitution = []byte("CNPJ")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}