re = /(me)(?!([^<]+)?>)/i
str = 'I have ever been prone to seek adventure and to investigate and experiment where <span class=\'me\'>wiser men</span> would have left well enough alone.'
subst = '<span class=\'highlight\'>$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result