using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(me)(?!([^<]+)?>)";
string substitution = @"<span class='highlight'>$1</span>";
string input = @"I have ever been prone to seek adventure and to investigate and experiment where <span class='me'>wiser men</span> would have left well enough alone.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}