re = /([A-Za-z0-9\._]+?)\s*(=|~|>|<)\s*(\".+?\"|[^\s)]+)/
str = 'RS ~ .*agent.* & RS ~ "No exlusions apply"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end