package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z0-9\._]+?)\s*(=|~|>|<)\s*(\".+?\"|[^\s)]+)`)
var str = `RS ~ .*agent.* & RS ~ "No exlusions apply"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}