$re = '/([A-Za-z0-9\._]+?)\s*(=|~|>|<)\s*(\".+?\"|[^\s)]+)/';
$str = 'RS ~ .*agent.* & RS ~ "No exlusions apply"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);