$re = '/^PMC[0-9]{7,8}$/m';
$str = 'PMC1234567
PMC12345678
PMC123456
PMC123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);