const regex = /^PMC[0-9]{7,8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^PMC[0-9]{7,8}$', 'gm')
const str = `PMC1234567
PMC12345678
PMC123456
PMC123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}