package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^PMC[0-9]{7,8}$`)
var str = `PMC1234567
PMC12345678
PMC123456
PMC123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}