import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(?=([^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "{ \"Activity\": \"ShortDescription\": \"01 Emiel Kool BizTallk\", \"Description\": \"01 Emiel Kool aangemmaakt via BizTalk\", \"Properties\": \"AutoPresent\": null, \"BPV\": false }, \"NameSpaces\": \"NameSpace\": \"TIO/Activiteiten\", \"NameSpaceType\": \"ACTIVITIES\", \"FromTime\": \"2015-07-29 00:00:00\" }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}