using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?=([^""]*""[^""]*"")*[^""]*$)";
string input = @"{ ""Activity"": ""ShortDescription"": ""01 Emiel Kool BizTallk"", ""Description"": ""01 Emiel Kool aangemmaakt via BizTalk"", ""Properties"": ""AutoPresent"": null, ""BPV"": false }, ""NameSpaces"": ""NameSpace"": ""TIO/Activiteiten"", ""NameSpaceType"": ""ACTIVITIES"", ""FromTime"": ""2015-07-29 00:00:00"" }";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}