re = /^[^#?]+\.([a-zA-Z0-9]+)(?:[?#].*)?$/
str = 'http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs.css?p=preview#test.json'
# Print the match result
str.match(re) do |match|
puts match.to_s
end