$re = '/^[^#?]+\.([a-zA-Z0-9]+)(?:[?#].*)?$/';
$str = 'http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs.css?p=preview#test.json';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);