using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^#?]+\.([a-zA-Z0-9]+)(?:[?#].*)?$";
string input = @"http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs.css?p=preview#test.json";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}