// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:[^\s]+\s++){4}(?<logical_system>[\w]+)[:\s]").unwrap();
let string = "Nov 15 02:51:46 CRTR2OTN.HKB VIASAT2OTN rpd[15644]: bgp_select_myaddr: peer 172.16.145.132 (External AS 64947) local address 172.16.145.129 unavailable, connection failed
Nov 15 02:51:44 CRTR2OTN.SIN rmopd[2167] pingCtlOwnerIndex = Rpm-Bgp-Owner, pingCtlTestName = Rpm-Bgp-Test-7";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}