$re = '/^(?:[^\s]+\s++){4}(?<logical_system>[\w]+)[:\s]/';
$str = 'Nov 15 02:51:46 CRTR2OTN.HKB VIASAT2OTN rpd[15644]: bgp_select_myaddr: peer 172.16.145.132 (External AS 64947) local address 172.16.145.129 unavailable, connection failed
Nov 15 02:51:44 CRTR2OTN.SIN rmopd[2167] pingCtlOwnerIndex = Rpm-Bgp-Owner, pingCtlTestName = Rpm-Bgp-Test-7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);