const regex = /^(?:[^\s]+\s++){4}(?<logical_system>[\w]+)[:\s]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^\\s]+\\s++){4}(?<logical_system>[\\w]+)[:\\s]', 'g')
const str = `Nov 15 02:51:46 CRTR2OTN.HKB VIASAT2OTN rpd[15644]: bgp_select_myaddr: peer 172.16.145.132 (External AS 64947) local address 172.16.145.129 unavailable, connection failed
Nov 15 02:51:44 CRTR2OTN.SIN rmopd[2167] pingCtlOwnerIndex = Rpm-Bgp-Owner, pingCtlTestName = Rpm-Bgp-Test-7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}