use strict;
my $str = '8 0 obj
<<
/Type /Page
/Parent 3 0 R
/Resources 9 0 R
/Contents [ 40 0 R 42 0 R 44 0 R 51 0 R 53 0 R 55 0 R 57 0 R 59 0 R ]
/TrimBox [ 42 42 2151 1573 ]
/BleedBox [ 36 36 2157 1579 ]
/MediaBox [ 0 0 2194 1615 ]
/CropBox [ 0 0 2194 1615 ]
/Rotate 0
>>
endobj';
my $regex = qr/\/(\w+)Box\ \[\ ?([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+)\ +([-]?\d+|[-]?\d+\.\d+)\ *?\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}