using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(\w+)Box\ \[\ ?([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+)\ +([-]?\d+|[-]?\d+\.\d+)\ *?\]";
string input = @"8 0 obj
<<
/Type /Page
/Parent 3 0 R
/Resources 9 0 R
/Contents [ 40 0 R 42 0 R 44 0 R 51 0 R 53 0 R 55 0 R 57 0 R 59 0 R ]
/TrimBox [ 42 42 2151 1573 ]
/BleedBox [ 36 36 2157 1579 ]
/MediaBox [ 0 0 2194 1615 ]
/CropBox [ 0 0 2194 1615 ]
/Rotate 0
>>
endobj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}