const regex = new RegExp('\\/(\\w+)Box\\ \\[\\ ?([-]?\\d+|[-]?\\d+\\.\\d+) +([-]?\\d+|[-]?\\d+\\.\\d+) +([-]?\\d+|[-]?\\d+\\.\\d+)\\ +([-]?\\d+|[-]?\\d+\\.\\d+)\\ *?\\]', 'gm')
const str = `8 0 obj
<<
/Type /Page
/Parent 3 0 R
/Resources 9 0 R
/Contents [ 40 0 R 42 0 R 44 0 R 51 0 R 53 0 R 55 0 R 57 0 R 59 0 R ]
/TrimBox [ 42 42 2151 1573 ]
/BleedBox [ 36 36 2157 1579 ]
/MediaBox [ 0 0 2194 1615 ]
/CropBox [ 0 0 2194 1615 ]
/Rotate 0
>>
endobj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}