// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<multi>mul\((?P<num1>\d*),(?P<num2>\d*)\))+|(?P<do>do\(\))+|(?P<dont>don't\(\))+").unwrap();
let string = "xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))
mul(6,9!
mul ( 2 , 4 )
mul(4*
?(12,34)
mul(123,4)
mul(44,46)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}