import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<multi>mul\\((?P<num1>\\d*),(?P<num2>\\d*)\\))+|(?P<do>do\\(\\))+|(?P<dont>don't\\(\\))+";
final String string = "xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))\n"
+ "mul(6,9!\n"
+ "mul ( 2 , 4 )\n"
+ "mul(4*\n"
+ "?(12,34)\n"
+ "mul(123,4)\n"
+ "mul(44,46)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}