re = /(?P<multi>mul\((?P<num1>\d*),(?P<num2>\d*)\))+|(?P<do>do\(\))+|(?P<dont>don't\(\))+/m
str = 'xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))
mul(6,9!
mul ( 2 , 4 )
mul(4*
?(12,34)
mul(123,4)
mul(44,46)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end