// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\d+)\.(?<minor>\d+)\.(?<patch>\d+)([\.\-](r|ls)?(?<build>\d+))(-ls(?<revision>\d+))?$").unwrap();
let string = "# linuxserver/prowlarr:1.16.2.4435-ls67
1.16.2.4435-ls67
# linuxserver/radarr:5.4.6.8723-ls215
5.4.6.8723-ls215
# linuxserver/sonarr:4.0.4.1491-ls236
4.0.4.1491-ls236
# linuxserver/transmission:4.0.5-r1-ls233
4.0.5-r1-ls233";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}