import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\\d+)\\.(?<minor>\\d+)\\.(?<patch>\\d+)([\\.\\-](r|ls)?(?<build>\\d+))(-ls(?<revision>\\d+))?$";
final String string = "# linuxserver/prowlarr:1.16.2.4435-ls67\n"
+ "1.16.2.4435-ls67\n\n"
+ "# linuxserver/radarr:5.4.6.8723-ls215\n"
+ "5.4.6.8723-ls215\n\n"
+ "# linuxserver/sonarr:4.0.4.1491-ls236\n"
+ "4.0.4.1491-ls236\n\n"
+ "# linuxserver/transmission:4.0.5-r1-ls233\n"
+ "4.0.5-r1-ls233";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}