re = /^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\d+)\.(?<minor>\d+)\.(?<patch>\d+)([\.\-](r|ls)?(?<build>\d+))(-ls(?<revision>\d+))?$/m
str = '# linuxserver/prowlarr:1.16.2.4435-ls67
1.16.2.4435-ls67
# linuxserver/radarr:5.4.6.8723-ls215
5.4.6.8723-ls215
# linuxserver/sonarr:4.0.4.1491-ls236
4.0.4.1491-ls236
# linuxserver/transmission:4.0.5-r1-ls233
4.0.5-r1-ls233'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end