re = /^(?<code>\+?\d{1,3})[-\s]{0,}(?<number>\(?\d{3}\)?[-\s]{0,}\d{3}[-\s]{0,}\d{2}[-\s]{0,}\d{2})$/m
str = '+447700150563
+14247323156
+12048170348
+33644628265
+78005553535
88005553535
8-800-555-35-35
8 800 555 35 35
8(800)5553535
8-(800)5553535
8-(800) 555 3535
8 (800) 555 3535'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end