#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<code>\+?\d{1,3})[-\s]{0,}(?<number>\(?\d{3}\)?[-\s]{0,}\d{3}[-\s]{0,}\d{2}[-\s]{0,}\d{2})$"
Local $sString = "+447700150563" & @CRLF & _
"+14247323156" & @CRLF & _
"+12048170348" & @CRLF & _
"+33644628265" & @CRLF & _
"+78005553535" & @CRLF & _
"88005553535" & @CRLF & _
"8-800-555-35-35" & @CRLF & _
"8 800 555 35 35" & @CRLF & _
"8(800)5553535" & @CRLF & _
"8-(800)5553535" & @CRLF & _
"8-(800) 555 3535" & @CRLF & _
"8 (800) 555 3535"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")